Using Aer with MAMP

mcenhill42's Avatar

mcenhill42

25 Oct, 2017 08:16 PM

I am having a lot of problems with getting Aer to connect to my local databases in MAMP. I get the error message:

Problem connecting to the database.
Communication link failure.

Then some text about how no packets have been received.

I am using the info MAMP gives me for host names, ports (8889), etc. I can connect to my MAMP websites and the data loads from the database, so MAMP is working correctly.

Am I missing something? Any advice on using Aer with MAMP?

  1. Support Staff 1 Posted by us on 26 Oct, 2017 12:11 AM

    us's Avatar

    Hi,
    Can you make sure you're using the port in the Preferences window of MAMP, not the port stated in their "welcome" page? I find that the port in the welcome page is often wrong!

    I've attached a screenshot showing what I mean.

    If that does not work, you can try making a new user, i.e. not "root", some servers are configured not to allow network connections using the root user.

    If that does not work, let me know and I'm sure we can sort it out.

    Thanks

    Garry

Discussions are closed to public comments.
If you need help with The Escapers please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

19 Nov, 2018 01:34 PM
11 Nov, 2018 04:30 PM
27 Sep, 2018 11:32 PM
04 Aug, 2018 06:03 PM
02 Aug, 2018 08:28 AM